Home
School Websites
Learning
Governor Support
System requirements 
Both JIT and J2E will run on a Windows PC and an Apple Mac.

On a Windows PC it will work on both Internet Explorer and Firefox.
On an Apple Mac we recommend using Firefox, rather than Safari.

JIT requires the latest version of Flash be installed for it to run. If Flash is not installed, then it will prompt you to install it, when you attempt to load JIT.
If not, it can be downloaded from here.

J2E requires the latest version of JAVA. Again this should be prompted for, but if it isn't, and you are experiencing problems, you can test for JAVA and download if required here.
Sign In